SAP Knowledge Base Article - Public

3727615 - Sales Order Item Shows No Quantity or Amount in Revenue Recognition Run

Symptom

The revenue recognition run does not generate any quantity or amount for a specific sales document item, even though a Customer Invoice exists.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Cost and revenue work center.
  2. Go to Revenue recognition view.
  3. Select and view the respective run ID XYZ (XYZ represents the Revenue recognition run ID). 
  4. Navigate to the Processed Successfully tab, select Advanced Information, and then open the Event-Based sub-tab.
  5. Notice that Sales document item ABC, the total invoice amount and total deferred revenues fields are empty. (ABC represents the Sales order ID).

Cause

This issue occurs because no customer invoice exists at the time the revenue recognition run is executed. The customer invoice is created only after the revenue recognition process has been completed.

  • To verify the creation date of the customer invoice, open the sales document items view and search the sales document item then choose reports and view Sales Document Line Items report and include the Created On (Journal Entry) field.

In SAP Business ByDesign, the revenue recognition run considers only those transactions that are posted on or before the posting date of the run. Documents with a later posting date are not included in the run.

 

Resolution

Since the invoice was not available at the time of execution, the invoice amount and corresponding deferred revenue were not included in the revenue recognition run.

 

Keywords

Revenue recognition, accrual method, total invoice amount, total deferred revenues , KBA , SRD-FIN-COR , Cost & Revenue , Problem

Product

SAP Business ByDesign all versions