Symptom
During the replication of Products to Sales Cloud V2, both mapping types "Material ID" and "Material Unformatted ID" entries are created and "defaultExternalProductId" is set; while for others only "Material Unformatted ID" entries are created.
Environment
- SAP Sales Cloud V2
- SAP Service Cloud V2
Reproducing the Issue
- Navigate to System Settings.
- Access the Message Monitoring section.
- Search and open the inbound message.
- Open the entity data associated with the message.
- Confirm that "defaultExternalProductId" is missing.
Cause
Initially, both ID mappings (formatted and unformatted) were created during product replication from ERP.
However, the MATMAS IDoc only provides the unformatted ID. As a result, the creation of the formatted ID mapping was removed during an iFlow update.
Resolution
- Implement the most recent iFlow update.
- Configure a post-exit to populate the formatted ID based on the required formatting rules.
Keywords
external product id mapping, material id, material unformatted id, integration inconsistency, defaultExternalProductId, MATMAS IDoc, iFlow update, product replication, backend integration, formatted id mapping, unformatted id mapping , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Problem
SAP Knowledge Base Article - Public