SAP Knowledge Base Article - Public

3728361 - Retry Mechanism for C4C Inbound Interface UtilitiesTechnicalObjectReplicationIn

Symptom

There are some inbound errors messages for C4C Interface UtilitiesTechnicalObjectReplicationIn in which the system didn`t automatically restart it.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Log on to the C4C system.
  2. Navigate to Administrator WC → General Settings WC View → Web Service Message Monitoring.
  3. Select "All" in the dropdown menu and search using the premise id.
  4. Observe that retries are not triggered for web service calls with application errors.

Cause

The retry mechanism of the C4C interface  UtilitiesTechnicalObjectReplicationIn is designed to handle locking errors and some very specific application errors.

Resolution

The retry mechanism is only available for the following errors:

  • Object Locking Errors
  • Premise does not exist 

  • Connection object does not exist

See Also

Keywords

retry mechanism, web service calls, qa system, locking errors, application errors, save process error, premise does not exist, connection object does not exist, utilities, web service message monitoring, error handling. , KBA , LOD-CRM-IND-UTL , Utilities , How To

Product

SAP Cloud for Customer core applications all versions