SAP Knowledge Base Article - Public

3728580 - Error message "Employee: Person External ID doesn’t exist" happened when importing Service Cost Level template in Manage Workforce

Symptom

  • An error occurs when attempting to upload a mass file with Agreement Work on App Manage Workforce F6097A.
  • Error message: "Employee: Person External ID doesn’t exist.".

Environment

SAP S/4HANA Cloud Public Edition

Cause

The issue is caused by missing worker agreements for the respective workers.

Resolution

When importing the Service Cost Level, it is necessary to ensure there is a work agreement for the respective worker as per How to Import Worker Data | SAP Help Portal.

-> However, if you want to assign a worker to a cost center or enter a company code, you need to create a work agreement for the respective worker. 

See Also

SAP Help Portal: How to Import Worker Data | SAP Help Portal

Keywords

error, employee, person external id, doesn’t exist, worker agreement, manage workforce app, mass upload, template, worker id, missing agreement, import worker data, cost center, company code, F6097A, service cost level , KBA , CA-GTF-BUM , Business User Management , CA-WFD-INT , S/4HANA Cloud Workforce Domain Integration , Problem

Product

SAP S/4HANA Cloud Public Edition all versions