Symptom
An error message occurs when checking connection in the Concur Integration Setup app.
Error message: "Re-execute the System Setup wizard to assign the access token.".
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- In the Concur Integration Setup app, Click System > Check Connection.
- Observe that the ping is successful (200 OK), but all API calls return 400 errors with the message: "Re-execute the System Setup wizard to assign the access token.".
Cause
The refresh/request token is missing from the current connection configuration.
Resolution
- Make sure the token is available. If you are unsure, you can generate a new one first.
- Enter the refresh/request token in the current connection configuration and check the connection again.
- If the issue persists after entering the token, delete the current connection and create a new one instead of modifying the existing connection.
See Also
3344911 - How to open a Concur case.
Keywords
error message, re-execute system setup wizard, access token, oauth token exchange, 403 forbidden, 400 error, integration setup, Concur, connection check, refresh token, S/4HANA Cloud Public Edition, API calls, token retrieval failure , KBA , BNS-CON-SE-S4-FIN , Concur S/4HANA Financial Integration , Problem
SAP Knowledge Base Article - Public