SAP Knowledge Base Article - Public

3728609 - An error message saying "Re-execute the System Setup wizard to assign the access token" appears when checking connection in the Concur integration Setup app – SAP S/4HANA Cloud Public Edition

Symptom

An error message occurs when checking connection in the Concur Integration Setup app.

Error message: "Re-execute the System Setup wizard to assign the access token.".

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. In the Concur Integration Setup app, Click System > Check Connection.
  2. Observe that the ping is successful (200 OK), but all API calls return 400 errors with the message: "Re-execute the System Setup wizard to assign the access token.".

Cause

The refresh/request token is missing from the current connection configuration.

Resolution

  1. Make sure the token is available. If you are unsure, you can generate a new one first.
  2. Enter the refresh/request token in the current connection configuration and check the connection again.
  3. If the issue persists after entering the token, delete the current connection and create a new one instead of modifying the existing connection.

See Also

3344911 - How to open a Concur case.

Keywords

error message, re-execute system setup wizard, access token, oauth token exchange, 403 forbidden, 400 error, integration setup, Concur, connection check, refresh token, S/4HANA Cloud Public Edition, API calls, token retrieval failure , KBA , BNS-CON-SE-S4-FIN , Concur S/4HANA Financial Integration , Problem

Product

SAP S/4HANA Cloud Public Edition all versions