SAP Knowledge Base Article - Public

3729030 - Customer reference field not visible in manage billing documents app for credit memo and credit memo returns - S/4 HANA Cloud Public Edition

Symptom

Customer reference field is not visible in the Manage Billing Documents app for credit memo and credit memo returns.

Environment

SAP S/4HANA Cloud Public Edition 

Reproducing the Issue

  1. Open the Manage Billing Documents app.
  2. Navigate to the billing document list for credit memo and credit memo returns.
  3. Observe that the customer reference field is not displayed in the document list.

Cause

This is system standard behavior, since in the billing document F2 reference is copied into the FI document as reference. When creating the credit memo request, this was created with reference to the billing document, this reference was copied into the reference in the accounting header information of the credit memo request.

When creating the credit memo, the reference field is copied from the credit memo request. The copy control logic is not executed, as reference is already filled, therefore customer reference field remains empty. If the reference field would be empty in the credit memo request, then according to the copy control setting the customer reference would be filled in both customer reference and reference fields.

Resolution

Create a custom routine using BAdI SD_BIL_DATA_TRANSFER. 

See Also

Keywords

customer reference field, manage billing documents app, credit memo, credit memo returns, billing document, reference field, copy control settings, accounting header information, Fiori app, standard behavior, public cloud. , KBA , SD-BIL-IV-2CL , Processing Billing Documents (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions