SAP Knowledge Base Article - Public

3729118 - Benefits Exception is not created automatically after reporting a life event - Employee Central

Symptom

After the Employee reports a work/life event, the exception is not being created as expected, even though the configuration is correct. 

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Log in as the employee;
  2. Report the event';
  3. Proxy as the approver;
  4. Approve the workflow;
  5. See the rule trace setting the exception as expected;
  6. No exception is created on the system.  

Cause

Incomplete configuration for Benefit Work/Life Event Configuration or missing permission to the "Benefits Email Configuration" object. 

Resolution

Make sure the "Benefits Email Configuration" object is created for the relevant Legal Entity and that the workflow approver has permission to the object.

For automatic exceptions, set Enable Email Notification to Yes in the Benefit Work/Life Event Configuration.

See Also

Configuring Email Notification for Benefits Exception
Creating Email Template Using Document Generation Template
Creating Benefits Email Configuration Object

Keywords

BENEFITS_NO_EMAIL_TEMPLATE, Benefits Email Configuration, permission, Enable Email Notification, Benefit Work/Life Event Configuration, exception, Document Generation Template, There is no email template configured for * entity {0} and the selected "Exception For" {1}. Please make the required configurations using the "Benefits Email Configuration" object. , KBA , LOD-SF-EC-GBF , Global Benefits , Problem

Product

SAP SuccessFactors HCM Core 2505