SAP Knowledge Base Article - Public

3729310 - Error "Customer name not maintained" While Generating Challan For Vendor Return

Symptom

The error “Customer name not maintained.” occurs when generating challan/outbound delivery for vendor return (movement type 161).

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Go to Delivery Challan for intrastate STO - India App
  2. Enter Company Code ABC (ABC represents the Company Code ID)
  3. Sending Plant (EFG) (EFG represents the Plant ID) 
  4. Posting Date. 
  5. Click on Vendor Return button
  6. Enter Vendor number XYZ (XYZ represents the Vendor number)
  7. Select Create Delivery Challan
  8. Click in Execute
  9. Click on Create Challan
  10. Click on "Display Log" to see the error "Customer name not maintained" 

Cause

Error occurs since the plant and supplier details are not maintained correctly. 

Resolution

We need to assign the customer Number for the Supplier/Vendor. 

  1. Go to the Maintain Business Partner App.
  2. Select the Vendor XYZ and BP role as Supplier.
  3. Under Supplier: General Data tab
  4. Maintain Customer Number

We need to assign the Plant to the Business Partner created for the Plant EFG

  1. Go to Maintain Business Partner App.
  2. Select the Business Partner created for the Plant EFG.
  3. Open BP role as Supplier.
  4. Maintain Plant EFG in the Supplier: General Data tab

Keywords

vendor return, challan generation, customer name not maintained, movement type 161, outbound delivery error, s/4hana cloud public edition, materials management, NB2 Enh. Return to Supplier, error message, logistics operations, inventory reconciliation. , KBA , FI-LOC-MM-IN , India (aka XX-CSC-IN-MM) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions