SAP Knowledge Base Article - Public

3729361 - Error: Email address * for email role TO is not valid inSAP S/4HANA Cloud Public Edition

Symptom

In the “Manage Automatic Payments” app, the output item fails with the error “Email address for role TO is not valid” and remains in error status.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Navigate to the app “Manage Automatic Payments”(F0770).
  2. Go to the tab 'Output items'.
  3. Send the output item.
  4. Observe that the output item fails with error:" Email address * for email role TO is not valid".

Cause

The error occurs due to a missing email address in Output Parameter Determination (OPD) or Supplier (Business Partner) master data.

Resolution

  • Follow these steps to maintain the email address in 'Output Parameter Determination'(OPD)app:
    1.  Navigate to the app 'Output Parameter Determination'(OPD).
    2. Select Payment Advice under Show Rules For
    3. choose Email Recipient in Determination Step, and maintain a valid email address.
  • Follow these steps to maintain the email address in app Maintain Business Partner (BP):
    1. Navigate to the app “Maintain Business Partner”(BP).
    2. Under the role Supplier (Fin. Accounting), go to the tab Vendor: Correspondence.
    3. Maintain the email in the field Clerk’s Internet Address (Internet address of partner company clerk).

Note: The system first checks the email in Output Parameter Determination(OPD) app; if not maintained, it retrieves it from the Business Partner master data.

See Also

Keywords

sender domain error, email settings, payment advice, output management, maintain business partner, allowed domains, scheduled payment advices, dispatch time, s/4hana cloud, email recipient error, correspondence settings , KBA , CA-GTF-OC , SAP S/4HANA output management , FI-FIO-AP-2CL , Fiori UI for Accounts Payable (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions