SAP Knowledge Base Article - Public

3729385 - Application error when submitting personal data collection step - Onboarding

Symptom

When initiating onboarding for any hire type through the API with dependent information, the visibility of dependent information to external has no value (the PerPerson entity record's visibility is not set to 'y').

This leads to an issue during the personal data collection (PDC) step, where the existing dependent data fails to load.

The error message displayed is: "An application error occurred. Please try again later, or notify support (with the error information of errorId=123456789123456789132, timestamp=2026-01-01T01:12:43.193+0000, and the version information from the current screen) if the issue keeps occurring."

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Attempt to submit the Personal Data Collection (PDC) step from the candidate's perspective.
  2. Observe the application error with the provided error ID and timestamp.

Cause

This is a known issue.

Resolution

The solution to this issue is currently under investigation.

Please follow this KBA for updates. Click on star to bookmark this article to receive updates about this issue. For more information about updates from subscribed KBAs, you can refer to the KBA 2171560 - How to be notified of new or updated SAP Notes or KBAs.

See Also

KBA 2171560 - How to be notified of new or updated SAP Notes or KBAs.

Keywords

application error, personal data collection, onboarding, dependent, information, visibility issue, PerPerson, entity, errorId=, timestamp, PDC, data load failure, custom MDF object, hire template, API issue, obx, onb , KBA , LOD-SF-OBX-PDC , Personal Data Collection , Problem

Product

SAP SuccessFactors Onboarding all versions