SAP Knowledge Base Article - Public

3729972 - Currency fields is not marked as mandatory in Account Sales Data using Dynamic Properties

Symptom

Currency fields is not marked as mandatory in Account Sales Data using Dynamic Properties

Environment

SAP Sales Cloud and SAP Service Cloud Version 2

Reproducing the Issue

Prerequisite:
You have a dynamic property under Account Sales Arrangement to mark Currency field as mandatory based on Division

  1. Go to Navigation Menu
  2. Go to Accounts
  3. Open any Account
  4. Go to Sales Data Facet
  5. Click Add
  6. Add a Sales Organisation
  7. Enter Distribution Channel and Division
  8. Click Add
  9. Make a change in the Account root fields
  10. The error for the Currency field does not appear

Cause

To evaluate the dynamic properties, it is very important to have the correct instance data. Hence, the updated data should be present in the UI context; otherwise, the dynamic properties will not be evaluated correctly.

Resolution

  1. Go to Navigation Menu
  2. Go to Accounts
  3. Open any Account
  4. Go to Sales Data Facet
  5. Click on User Menu
  6. Click Start Adaptation
  7. Click on the Add button for the Sales Data section
  8. Select the pencil icon
  9. Add the Currency field
  10. End Adaptation
  11. Now when you try to add the Sales Data, the currency field is marked as mandatory during creation itself as the field is part of the UI context

Keywords

dynamic, properties, account, sales, data, currency, division, mandatory, not , KBA , CEC-CRM-ACC , Account for SAP Sales/Service Cloud , CEC-CRM-CZM , Customization for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0