SAP Knowledge Base Article - Public

3730132 - Error in ARM process when changing follow up activity in inspection document

Symptom

When using Advanced Returns Management, a follow-up activity was selected, for example "Ship-to Supplier", and the follow up flow was completed .

For some reason, there's was the need to change the follow up activity, so the entire flow related to "Ship-to Supplier" was reversed and the follow up activity was changed in the inspection document for another one, for example "Send back to Customer".

Although, when following the flow for the new follow up activity, the process cannot continue due to unspecified errors in the document creation for this new activity.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Create a returns order of type CBAR, enter the necessary data and select the follow up activity as 'Ship-to Supplier'.
  2. Release the refund selected, e.g. Credit Memo Request and subsequent Credit Memo.
  3. Process the returns delivery.
  4. On app 'Enter Inspection Results - From Warehouse' realize the inspection, creating the inspection document.
  5. Create and process the entire flow for activity 'Ship-to Supplier' (e.g. Returns Purchase Order, Outbound Delivery, Invoice Verification, etc).
  6. Reverse the entire flow for the activity 'Ship-to Supplier' (cancel, reject or delete the documents).
  7. In the inspection document, change the follow up activity to 'Send back to Customer' and trigger the processing.
  8. The first document cannot be created due to errors.

Cause

The returns flow was not entirely reversed before changing the follow up activity.

Resolution

The entire document chain should be reversed before changing the follow up activity. Delete all subsequent documents and change the follow up activity on the returns order instead of in the inspection document.

Note: to make sure the returns flow was entirely reversed, the returns order will go back to status 'Open'.

Keywords

ARM, returns order, customer return, CBAR, 0005, 0021, follow up activity, no log exists in the database, Process with Errors, inspection document, reversing, document chain, document flow , KBA , LO-ARM-SD-2CL , Sales (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions