SAP Knowledge Base Article - Public

3730566 - Explorer Content Not Refreshing Automatically in SAP Signavio Process Manager

Symptom

  • Content in the Explorer is not refreshing automatically
  • Publishing of process flows in Process Manager is inconsistent, with old versions being published
  • Version control in Process Manager does not reflect changes automatically“Last updated” timestamps are not updating correctly in Process Manager Explorer
  • Changes made to processes are not visible in the workspace until manually refreshing the view

Cause

The above behavior is expected.

The deactivation of the automatic refresh in the Explorer was an intentional decision as part of a performance optimization initiative in the SAP Signavio Process Manager Explorer.

This change was implemented globally and cannot be activated for specific tenants.
It was done to ensure system stability and improve performance in large workspaces.

In SAP Signavio Process Collaboration Hub, there is also no auto‑refresh. As explorer functionalities are progressively moved into Collaboration Hub, SAP will consider this requirement in future development. However, no specific timeline can be provided.

Official Release Note (September 1, 2025):
https://help.sap.com/whats-new/7932fa5931074f1180483a9463aa5055?locale=en-US

The release note states:

“Automatic Refresh deactivated – In the process of aligning functions across the SAP Signavio Process Transformation Suite, we have deactivated the automatic refresh in the explorer. You can refresh the explorer manually with the Refresh button in the top right corner of the explorer or by reloading your browser window.”

Resolution

Users must manually refresh the Explorer view to see the most up‑to‑date content.

How to Refresh

  • Use the Refresh button in the top right corner of the Explorer
  • Or reload the browser window (e.g., F5)

Recommendation

We recommend refreshing actively used Explorer tabs regularly to stay current with changes made concurrently in other tabs or by other users.

Official Documentation

User Guide:
https://help.sap.com/docs/signavio-process-manager/user-guide/explorer-view?locale=en-US#refreshing-the-explorer-view

See Also

https://help.sap.com/whats-new/7932fa5931074f1180483a9463aa5055?locale=en-US
https://help.sap.com/docs/signavio-process-manager/user-guide/explorer-view?locale=en-US#refreshing-the-explorer-view

Keywords

Auto-refresh disabled; Automatic refresh not working; Explorer not refreshing; Explorer auto-refresh; Manual refresh disabled, Old Versions Published; Publishing Issue;
, KBA , BPI-SIG-PM-EXP , Explorer for SAP Signavio Process Manager , Problem

Product

SAP Signavio Process Manager all versions