SAP Knowledge Base Article - Public

3730721 - The Products are not replicated with the same ID from S4 to CNS

Symptom

The Products are not replicated with the same ID from S4 to CNS.

Environment

  • SAP Sales Cloud Version 2 Integration with SAP ERP / SAP S4HANA.
  • SAP Service Cloud Version 2 Integration with SAP ERP / SAP S4HANA.

Reproducing the Issue

You are replicating Products from S4 to CNS but you have observed that the system are not replicating the Products with the same ID from S4 to CNS. 

Cause

To keep the Products with the same ID from S4 to CNS you must ensure that the iFlow parameter "Default S4 ID" is set as "true". 

Resolution

On the iflow:

  1. Go to "Configure".
  2. Go to  "More".
  3. Set the "Default S4 ID" as true.

 

Keywords

Default S4 ID, Product Internal ID, Product External ID.  , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 all versions