SAP Knowledge Base Article - Public

3730767 - Special Characters Not Displayed Correctly In Autoflow Email Subject

Symptom

Email subjects configured with placeholders containing special characters display scrambled or HTML-escaped text in email notifications.

Environment

SAP Sales Cloud and SAP Service Cloud Version 2

Reproducing the Issue

  1. Go to Settings.
  2. Navigate to Templates.
  3. Configure an 'Autoflow Subject Template' that uses a placeholder (for example, Category Level 1 Name).
  4. Assign the subject template to an autoflow (for example, for Case Entity) that sends email notifications and activate the Autoflow.
  5. Go to Cases and open a Case in Detail View.
  6. Make a change such that the Autoflow is triggered.
  7. Observe that the Email subject shows HTML-escaped entities for special characters (for example, &amp instead of &).

Cause

HTML character escaping occurs in plain text subject templates when placeholders output values containing special characters.

Resolution

For any placeholder that can output special characters, replace the double-curly form {{placeholder}} with the triple-curly form {{{placeholder}}}. This renders the raw value and prevents HTML character escaping in plain text subjects.

See Also

KBA 3452302 - Response template placeholder not working

Keywords

Autoflow Subject Template, Email Subject Placeholder, Special Characters, Html Escaping, Autoflow, Email, Display, Character, Service Cloud, Template , KBA , CEC-CRM-TMP , Templates for SAP Sales/Service Cloud , CEC-CRM-EML , Emails for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 all versions