SAP Knowledge Base Article - Public

3731193 - Calendar process tasks automatically delayed at start date without errors - SAP Analytics Cloud

Symptom

  • In a calendar process with sequential tasks, tasks are automatically set to Delayed at the planned start date.
  • No error or warning messages are shown.
  • Subsequent tasks in the same process are impacted.
  • Tasks may transition from Delayed to Overdue.

Environment

SAP Analytics Cloud

Reproducing the Issue

  1. Open the calendar.
  2. Use a calendar process that contains sequential tasks with a defined start date/time.
  3. Activate the process.
  4. Observe that at the start date/time, tasks automatically switch to Delayed without any error or warning.

Cause

  • “No End Date” is selected for the scheduled publication, which is deprecated.

Resolution

  1. Open the affected calendar task.
  2. Edit the scheduled publication configuration for the task.
  3. Set a valid End Date (avoid using “No End Date”).
  4. Save the configuration.
  5. Repeat the same for all related scheduled publications within the process.
  6. Reactivate or reschedule the process/tasks and monitor the next run.

Keywords

calendar process, sequential tasks, delayed status, overdue, start date, no error, scheduling, publication, no end date, deprecated option, sac calendar, planning process, calendar task, input task, automatically delayed , KBA , LOD-ANA-PL-PRO , Planning Process, Input Task, Calendar Task , Problem

Product

SAP Analytics Cloud all versions