SAP Knowledge Base Article - Public

3731286 - Behaviour of (ONB) New Team Member Onboarding Restarted Trigger

Symptom

  • The following Restart Onboarding Emails are not getting triggered after restarting an onboardee
    • (ONB) New Team Member Onboarding Restarted - Hiring Manager
    • (ONB) New Team Member Onboarding Restarted
  • The custom Restart Onboarding Emails are triggered at the same time for the candidate and the Hiring Manager
  • Immediately after the onboarding process is restarted, the Onboarding Restarted Email Template has not been triggered.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Login to the instance as an admin or Hiring Manager.
  2. Go to the Onboarding Dashboard.
  3. Locate the candidate that needs to be restarted.
  4. View Details for the candidate
  5. Restart the onboarding from the 'Actions' tab.
  6. Go to Email Services and see that no Restart onboarding emails are triggered.

Cause

  • Emails are triggered in onboarding based on specific trigger points.
  • In case of (ONB) New Team Member Onboarding Restarted Trigger, the trigger point is set when New Hire Data Review is completed.
    For example: If the candidate has completed New Hire Data Review and then the onboarding process was restarted, the email will not trigger immediately. It will only trigger after New Hire Data Review is completed again, post restart. 

Resolution

  • Kindly make sure that "(ONB) New Team Member Onboarding Restarted Category" and "(ONB) New Team Member Onboarding Restarted Trigger" are added to the following email templates:
    • (ONB) New Team Member Onboarding Restarted - Hiring Manager
    • (ONB) New Team Member Onboarding Restarted
  • In this case, once the email templates has been customized, make sure that the Hiring Manager completes the New Hire Data Review step first. After completion, both emails are triggered successfully.

NOTE: 

  • We have an enhancement to ensure that the email template "(ONB) New Team Member Onboarding Restarted - Hiring Manager" would be triggered after the onboarding process is restarted rather than after New Hire Data Review is completed. 
  • This enhancement is a part of our future roadmap (standard roadmap guidelines are applicable), and it can be tracked via OBX-15080.
  • However, the template "(ONB) New Team Member Onboarding Restarted" template will trigger to the onboardee after New Hire Data Review is completed. There is no change in behaviour planned for this email template.

Keywords

OBX-15080, (ONB) New Team Member Onboarding Restarted, (ONB) New Team Member Onboarding Restarted - Hiring Manager, Restarted, Onboarding Restart, Email, Onboardee, Onboardee restart, Hiring Manager, External Candidate, New Team Member, New Hire Restart, New Hire, (ONB) New Team Member Onboarding Restarted Category, (ONB) New Team Member Onboarding Restarted Trigger , KBA , LOD-SF-OBX-NF , Notifications Framework , How To

Product

SAP SuccessFactors Onboarding all versions