Symptom
When a user declines a form during data collection, the declined form cannot be accessed again for signature. If the related Custom Task is reopened, the Submit button is disabled or greyed out, preventing the user from completing the task. No specific error message is displayed.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- A Custom Task is triggered and completed by the new hire with the required data.
- A corresponding document flow is created for the Custom Task.
- The document is declined.
- The Custom Task is reopened for completion (previous data is retained).
- Attempt to submit the task, with or without making any changes.
- The Submit button is disabled, preventing the user from completing the task.
Cause
This is a Known Issue.
Resolution
Product Engineering is investigating a solution.
Click on star to bookmark this article to receive updates about this issue. For more information about updates from subscribed KBAs, you can refer to the KB Article 2171560 - How to be notified of new or updated SAP Notes or KBAs.
Workaround
The task can be completed by opening it from the dashboard using an admin or manager account. In this view, the Submit button is enabled, allowing the task to be completed successfully.
See Also
- SAP SuccessFactors Product Release & Road Map Information
- SAP SuccessFactors Patches Knowledge Base
- KB Article 2171560 - How to be notified of new or updated SAP Notes or KBAs
Keywords
KI2H2025, OBX-42651, submit, button disabled, greyed, out, onboarding, custom, task, declined, form, forms, e‑signature, blocked, restart, compliance, document, flow, resubmit , KBA , LOD-SF-OBX-DOC , Generation of Documents using PFS , Bug Filed
SAP Knowledge Base Article - Public