SAP Knowledge Base Article - Public

3731874 - Reopened Custom Task shows disabled Submit button following a declined form - Onboarding

Symptom

When a user declines a form during data collection, the declined form cannot be accessed again for signature. If the related Custom Task is reopened, the Submit button is disabled or greyed out, preventing the user from completing the task. No specific error message is displayed.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. A Custom Task is triggered and completed by the new hire with the required data.
  2. A corresponding document flow is created for the Custom Task.
  3. The document is declined.
  4. The Custom Task is reopened for completion (previous data is retained).
  5. Attempt to submit the task, with or without making any changes.
  6. The Submit button is disabled, preventing the user from completing the task.

Cause

This is a Known Issue.

Resolution

Product Engineering is investigating a solution.

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Workaround

The task can be completed by opening it from the dashboard using an admin or manager account. In this view, the Submit button is enabled, allowing the task to be completed successfully.

See Also

Keywords

KI2H2025, OBX-42651, submit, button disabled, greyed, out, onboarding, custom, task, declined, form, forms, e‑signature, blocked, restart, compliance, document, flow, resubmit , KBA , LOD-SF-OBX-DOC , Generation of Documents using PFS , Bug Filed

Product

SAP SuccessFactors Onboarding all versions