Symptom
The system calculates Mean Time to Repair (MTTR) and Mean Time Between Repair (MTBR) based on a continuous 24-hour clock, without accounting for break hours and shift schedules maintained in the Work Center.
For example, if a breakdown occurs at 4:00 PM on Friday and is repaired at 9:00 AM on Monday, the system calculates 65 hours of downtime instead of subtracting non-working hours such as weekends and overnight shifts.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
Cause
This is the current system design.
Resolution
MTTR and MTBR are currently designed to calculate breakdown time on a real-time basis (24 hours per day) and do not consider factory calendars or work center capacity or shift breaks.
There is no configuration available to change these KPIs to operating-hours-based calculations at this time.
For future consideration of operating-hours-based MTTR/MTBR, submit a feature request via Customer Influence.
Refer 2963059 - How to Submit Feature Requests for SAP S/4HANA Cloud Product.
See Also
Keywords
mttr, mtbr, mean time to repair, mean time between repair, breakdown duration, 24-hour calculation, factory calendar, work center shifts, capacity calendar, non-working hours, downtime calculation, asset management kpis, public cloud, by design, operating hours , KBA , PM-FIO-2CL , Fiori User Interface (UI) for PM (Public Cloud) , Problem
SAP Knowledge Base Article - Public