Symptom
A custom query created for Tickets does not appear in the query dropdown for specific users/roles when creating a homepage quick link card.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Homepage
- Create a "Quick Link" tile
- Select Tickets Object
- In the "Query" dropdown, the required custom query is not available
Cause
Different user roles access different Ticket work center views, one is Service Work Center -> Tickets work center view; another one is Tickets Work Center. Need to confirm which view user/role assigned and if the custom query visible in this view.
Resolution
Go to Work Center and View Assignment, compare the work center assigned for working case and non-working case. Confirm the assigned work center view included the custom query.
See Also
Keywords
homepage quick link, custom card, custom query missing, query dropdown, tickets work center, role-based difference, OWL component, adaptation mode, primary layout, query not listed, home page tile, ticket view mismatch, UI component path, C4C home, query visibility , KBA , AP-RC-UIF , C4C UI Framework , Problem
SAP Knowledge Base Article - Public