Symptom
After doing an HCM Token Server API call and then attempting to do an LMS API call, the response received is stating:
- You do not have permission to perform this action.
Environment
- SAP SuccessFactors Learning
- SAP SuccessFactors HCM
Cause
- Incorrect Permissions for the Learning Admin or User account (depending on the API call)
- The UserID value that is used in the SAML Properties of the HCM Token API call does not match the Learning Admin ID
Resolution
Incorrect Permissions
- Go to Learning Administration
- Go to System Administration > Security > Role Management
- Edit the user and/or admin role > Permissions tab > Add one more > Add in the permissions that are associated to the entity data that the API call is trying to pull
Mismatch of User IDs
- In HCM > Search and access Employee Export
- Export the user file and open it up to validate the UserID column
- Go to Learning Administration > System Administration > Security > Administrators > Search for the Admin
- If the Admin ID is different from the HCM User ID, select Create New and create a new Admin with the proper ID
- In the new Admin record > Assigned Roles tab > add in the proper role for the admin and update the Related User field on the Summary tab if there is a corresponding Learning User
See Also
Keywords
oauth token, hcm token server, lms token server removed, actingAs=admin, domainservicevalidator, action.restricted, permission error, companyId, authorization header, lms api, public api , KBA , LOD-SF-LMS-ODA , Web Services OData , Problem
Product
SAP SuccessFactors Learning all versions
SAP Knowledge Base Article - Public