SAP Knowledge Base Article - Public

3733910 - Address Section/Fields Visibility in Primary Emergency Contact Portlet

Symptom

  • Address fields(Country, State, District, etc.) are not displayed when adding or editing a primary emergency contact in People Profile.
  • This behaviour can be observed in both the legacy People Profile (PP3) and the latest People Profile (PPX).

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors Employee Central - Emergency Contact Details.

Reproducing the Issue

  1. Log in to the instance.
  2. Navigate to Manage Business configuration (BCUI).
  3. Under the emergencyContactPrimary HRIS element, disable the field "isAddSameAsEmployee".
  4. Navigate to the profile of a user in the latest People Profile, go to Personal Data -> Primary Emergency Contact Details -> View/Edit, and notice that the fields of the address section are not visible.
  5. Similarly, navigate to the profile of a user in the legacy People Profile, click on Edit in the Primary Emergency Contact section -> click on "Edit Details", and notice that the address fields are not visible. 

Cause

The field isAddSameAsEmployee in the emergencyContactPrimary element is disabled, which prevents the address section from appearing in the Primary Emergency Contact portlet.

Resolution

  1. The engineering team have confirmed that the visibility of the address fields in the Primary Emergency Contact portlet is controlled by the enablement of the field isAddSameAsEmployee in the emergencyContactPrimary element.
  2. Field isAddSameAsEmployee Disabled: When the field isAddSameAsEmployee is disabled, the address fields (Country, State, District, etc.) are not visible in the Primary Emergency Contact portlet in both the latest People Profile (PPX) and the legacy People Profile (PP3), even after clicking "Edit Details".

  3. Field isAddSameAsEmployee Enabled: When the field isAddSameAsEmployee is enabled, the address fields become visible in the Primary Emergency Contact portlet in PPX and in PP3 after clicking "Edit Details".

  4. If you would like to enhance the product and to have this functionality, please request an enhancement request as per KBA 2090228 mentioning the requirement and business needs so that product team can assess and implement the functionality based on feasibility.

See Also

Keywords

emergency contact, address not showing, primary emergency contact, isAddSameAsEmployee, emergencyContactPrimary, address section missing, manage business configuration, people profile, address portlet, field disabled, visibility, PPX,PP3, layout, emergency contact address. , KBA , LOD-SF-EC-PER-ECO , Emergency Contact Details , Problem

Product

SAP SuccessFactors Employee Central all versions