Symptom
The error "Unexpected response received. Contact technical support." is displayed for eDocument from the Country Poland.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open the eDocument Cockpit app.
- Select any available eDocument for Poland.
- Choose Go to… -> Application Log.
The error “Unexpected response received. Contact technical support.” is displayed.
Cause
Authorization inconsistency in the communication arrangement for Poland due to missing authentication or an outdated certificate.
Resolution
The communication arrangement maintained for Poland must be reviewed to verify whether any authentication settings are incorrectly maintained or if any certificates are outdated.
See Also
Community Blog: Document and Reporting Compliance for Poland (S/4HANA Cloud)
Keywords
edocument cockpit, poland, ksef 2.0, unexpected response received, EDOCUMENT099, application log, communication arrangement, authentication, certificate, authorization , KBA , CA-GTF-CSC-EDO-PL , Document Compliance Poland , Problem
SAP Knowledge Base Article - Public