Symptom
- When selecting a specific goal plan template in Objective Management Data for a Story report, the Category column is not visible and cannot be pulled.
- The Category can be pulled when “All Templates” is selected in Objective Management Data.
Environment
- SAP SuccessFactors Performance & Goals
Reproducing the Issue
- Go to Reporting.
- Create a Story report.
- Use the specific goal template table under Objective Management Data.
- Observe that the Category column is not visible.
Cause
The issue arises due to limitations in accessing the Category field when selecting a specific goal plan template in Objective Management Data.
Resolution
Workaround:
- Add the control-category-element into the XML https://help.sap.com/docs/successfactors-performance-and-goals/implementing-and-managing-goal-management/defining-category-and-default-category?version=2505
- Or, Include all templates when creating the report.
See Also
Keywords
story report, objective management data, goal management, goal plan template, specific template, all templates, category field, primary goal fields, category column missing, category not visible, category no data, reporting, template filter, goal category, successfactors goals , KBA , LOD-SF-GM-ADM , Admin Tools, Settings, Permissions , Problem
Product
SAP SuccessFactors Performance & Goals 2505
SAP Knowledge Base Article - Public