SAP Knowledge Base Article - Public

3734734 - Displaying branch line items on head‑office balance‑confirmation letters – SAP S/4HANA Cloud Public Edition

Symptom

Explain when branch line items appear on a head‑office balance‑confirmation letter and how to view them in app "Manage Customer/Supplier Line Items".

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental." 

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Open the app "Schedule Accounts Receivable Jobs" and start the job template “Customer Balance Confirmation”.
  2. After scheduling the job, open the “Manage Balance Confirmation” app.
  3. Open the generated PDF form and review the document.
  4. In apps "Manage Customer/Supplier Line Items", check the "Branch Account No." column.

Cause

There are several reasons why the function is not working as expected:

  • Missing branch items on HO letter: Ensure the "Branch Account No." is populated, the HO-BR link exists, the item is open, and the selection criteria include the HO.

  • No branch letter: Confirm there are open items posted directly to the branch (Customer = BR).

  • Column "Branch Account No." not visible in app "Manage Customer/Supplier Line Items": Add it via the app personalization or layout variant.

Resolution

1. Confirm head‑office (HO) and branch (BR) link is maintained in the master data. Head‑office and branch link is maintained in the company‑code dependent master data. Refer to apps "Manage Customer Master Data" respectively "Manage Supplier Master Data" 🡪 Section Company Codes 🡪 Field Head Office.

2. Post test items. Open line items posted using Customer/Supplier = Head Office, Branch Account No = Branch.

  • Case A: Customer = HO, Branch Account No = BR (open).
  • Case B: Customer = HO, Branch Account No = empty (open).
  • Case C: Customer = BR, Branch Account No = empty (open).

3. In Manage Customer/Supplier Line Items add column "Branch Account No" and filter by HO - you should see the items of cases A and B.

  • All items with Customer = 10105061 appear on the head office letter (cases A and B).
  • The last two items at the bottom are posted directly on the branches 1015062 / 1015063. These items represent case C and appear on separate letters for the two branches.

4. Run balance confirmation for HO and BR.

  • The letter for the HO should include A and B (Line items with Customer = Head Office and Branch Account No filled appear on the head‑office’s confirmation together with the head‑office items).
  • A separate branch letter for BR appears only if items like C exist (A separate branch confirmation letter is required only if there are open items posted directly to the branch (Customer = Branch)).

Keywords

balance confirmation, head office, branch, no open items on key date, accounts receivable, customer balance confirmation, manage balance confirmation, open items missing, pdf form, schedule accounts receivable job, period end, public cloud. , KBA , FI-AR-AR-G-2CL , Closing Operations / Period-End (Public Cloud) , How To

Product

SAP S/4HANA Cloud Public Edition all versions