Symptom
A manually created Registered Product cannot be created without populating Mandatory fields such as Serial ID and Account.
Environment
SAP Service Cloud Version 2
Reproducing the Issue
- Go to Registered Products
- Choose + to manually create a new Registered Product
- Save Registered Product without filling in Account or Serial ID
- Errors observed such as "Enter a Serial ID" or Enter Customer
Cause
This is standard behavior however there is a workaround option that can be configured which allows you to then create a Registered Product without having to populate mandatory fields such as Account, Serial ID and Individual Customer
Resolution
Step 1:
- Go to User Menu
- Go to System Settings
- Search for Registered Products
- Open Categories
- Add a new Registered Product Category and Save
Step 2:
- Go to Registered Products
- Create manual Registered Product
- Enter a value for mandatory field Product
- From the Dropdown for "Registered Product Category" choose the new Category you have created
- Leave Account, Individual Customer and Serial ID blank even though they are listed as mandatory fields
- Save Registered Product and see that it is created.
Keywords
registered product, serial id optional, customer optional, account optional, ui mandatory indicator, asterisk, account field, serial number field, save without serial, save without account, create registered product, equipment replication, s4 replication, service cloud v2, field requirement , KBA , CEC-CRM-RPD , Registered Products for SAP Sales/Service Cloud , Problem
SAP Knowledge Base Article - Public