SAP Knowledge Base Article - Public

3734820 - When manually creating Registered Product both Serial Number and Account fields are Mandatory

Symptom

A manually created Registered Product cannot be created without populating Mandatory fields such as Serial ID and Account.

Environment

SAP Service Cloud Version 2

Reproducing the Issue

  1. Go to Registered Products 
  2. Choose + to manually create a new Registered Product
  3. Save Registered Product without filling in Account or Serial ID
  4. Errors observed such as "Enter a Serial ID" or Enter Customer

Cause

This is standard behavior however there is a workaround option that can be configured which allows you to then create a Registered Product without having to populate mandatory fields such as Account, Serial ID and Individual Customer

Resolution

Step 1:

  1. Go to User Menu
  2. Go to System Settings
  3. Search for Registered Products
  4. Open Categories
  5. Add a new Registered Product Category and Save

Step 2:

  1. Go to Registered Products
  2. Create manual Registered Product 
  3. Enter a value for mandatory field Product
  4. From the Dropdown for "Registered Product Category" choose the new Category you have created
  5. Leave Account, Individual Customer and Serial ID blank even though they are listed as mandatory fields
  6. Save Registered Product and see that it is created.

Keywords

registered product, serial id optional, customer optional, account optional, ui mandatory indicator, asterisk, account field, serial number field, save without serial, save without account, create registered product, equipment replication, s4 replication, service cloud v2, field requirement , KBA , CEC-CRM-RPD , Registered Products for SAP Sales/Service Cloud , Problem

Product

SAP Service Cloud Version 2 all versions