SAP Knowledge Base Article - Public

3734972 - Ticket Summary: Email Content Missing in PDF

Symptom

When generating the service ticket summary, one email interaction does not show the content / text of the email.

The same plain content text is missing in the downloaded XML data for the document and it is missing in the Activities work center, when opening the email.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Service.
  2. Open Tickets and select the affected service ticket.
  3. From Actions, choose Generate Summary.
  4. Select the form template “Service Request” and choose Preview.
  5. Observe that one email interaction does not show the content / text of the email.

Cause

The text of workflow emails is processed differently than regular email activities. The ticket summary cannot access this email text.

Resolution

The text of workflow emails is not accessible for the ticket summary and cannot be shown in the PDF.

Keywords

service ticket xml, email interaction, plain content missing, interaction text only, generate summary, pdf preview, print form preview, service request template, xml data extraction, first email missing content, c4c service tickets, document xml, ticket summary, email body missing, form template xml , KBA , LOD-CRM-SRP , Service Request Processing , Product Enhancement

Product

SAP Cloud for Customer core applications all versions