Symptom
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Observe if they are using proxy or direct affected user
- Check the per person UUID in SF and SAC
- Compare the ID mapped in SAC backend and see if it is matching
- Per person UUID (SF) = Custom Attribute (IAS) = username (SAC)
Cause
The issue occurs when the user still exists in IAS (SAC) but has already been deleted or purged in SuccessFactors.
Example: In a preview instance where the customer tests several users, they may delete a user and create it again using the same email address or username. The new user will not be synced to IAS because the previous IAS entry still exists using the same email address or username.
As a result, the user can create new stories or change the author, but instead of their current name, the old SAC ID will appear.
Resolution
Confirm the information below:
- A unique email address
- Username
- Custom Attribute 1 with correct UUID
- Access to the Report Center and Story permissions
- Inclusion in the Refresh Synthetic Group Data job (if the customer is using API v2)
See Also
Keywords
author name, story, report, SF, SuccessFactors, sync issue, stories, SAC, IAS , KBA , LOD-SF-ANA-RCT-SAC , People Analytics Stories , Problem
SAP Knowledge Base Article - Public