Symptom
The "LastChangeDateTime" field in the ServiceRequestCollection node of the C4C OData API is not updated when a utilities exception document is created from the ticket object (for example, a BTD reference such as a clarification case).
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Service Work Center.
- Go to Tickets Work center view.
- Go to Generate Exceptions
- Go to changes tab the latest time from Reference Document ID and Reference Document Type is not captured at Root level.
- Go to the overview tab.
- Go to timeline section the value in changed on field remains as old one and LastChangeDateTime via Odata don't capture the latest change time
Cause
When a BTD reference document (such as a utilities exception/clarification case) is added to a ticket, only the BTD reference is updated and the ticket root is not updated, so the “Changed On” field (and therefore OData LastChangeDateTime) does not change.
Resolution
This is the limitation
Keywords
LastChangeDateTime, ServiceRequestCollection, OData, service ticket, changes tab, ticket, changed on, timeline, BTD reference, utilities exception, Reference Document ID, not updated, API, changes tab, limitation,Reference Document Type,changed on. , KBA , LOD-CRM-SRP , Service Request Processing , Problem
SAP Knowledge Base Article - Public