SAP Knowledge Base Article - Public

3735241 - LastChangeDateTime is not updated in Odata when utilities exception/BTD reference is created from a ticket

Symptom

The "LastChangeDateTime" field in the ServiceRequestCollection node of the C4C OData API is not updated when a utilities exception document is created from the ticket object (for example, a BTD reference such as a clarification case).

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Service Work Center.
  2. Go to Tickets Work center view.
  3. Go to Generate Exceptions 
  4. Go to changes tab the latest time from Reference Document ID and Reference Document Type is not captured at Root level.
  5. Go to the overview tab.
  6. Go to timeline section the value in changed on field remains as old one and LastChangeDateTime via Odata don't capture the latest change time 

Cause

When a BTD reference document (such as a utilities exception/clarification case) is added to a ticket, only the BTD reference is updated and the ticket root is not updated, so the “Changed On” field (and therefore OData LastChangeDateTime) does not change.

Resolution

This is the limitation

Keywords

LastChangeDateTime, ServiceRequestCollection, OData, service ticket, changes tab, ticket, changed on, timeline, BTD reference, utilities exception, Reference Document ID, not updated, API, changes tab, limitation,Reference Document Type,changed on. , KBA , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer core applications all versions