Symptom
- In the analytic model preview, when using a Fact View as source, selecting Insert Value > Select Value in a filter or restricted key figure displays the list of available members
- When an Analytic Model is used as the source (stacked analytic model), selecting Value Help does not show no data or
- Warning: "Please set values for all mandatory variables" or
- OData error code observed: "SERVICE_BAD_REQUEST"
- Error detail observed: "Expected at least one key predicate but found none"
Environment
- SAP Datasphere
Reproducing the Issue
- In an analytic model sourced from a Fact View, add a dimension filter or create a restricted key figure, enter an expression (for example: = ), and choose Insert Value > Select Value. The member list appears.
- In a stacked analytic model (an analytic model that uses another analytic model as its source), add a similar filter or restricted key figure and choose Insert Value > Select Value. The selection dialog does not load any values.
Cause
When a parameter/variable in the source analytic model is not marked mandatory, the stacked analytic model expects a default value to be defined. Without a default value, the value help in the consuming model cannot resolve members and returns no data.
Resolution
For each non-mandatory variable, define a suitable default value in the source analytic model.
See Also
refer to: Note 3638685 - Missing value from Fact View in Analytic Model filter search
refer to: Note 3446581 - No data in input help for restricted measures with time-dependency
refer to: Note 3572409 - Value help not available for input parameters in stories based on Datasphere models
Keywords
analytic model, stacked analytic model, value help, select value, insert value, restricted key figure, rkf, filter, variable default value, non-mandatory variable, odata, service_bad_request, member list, analytic model editor, datasphere, restriction variable, variable , KBA , DS-MD-AM , Analytic Model , DS-BB-ODATA , To address issues related to Odata consumption API , Problem
SAP Knowledge Base Article - Public