SAP Knowledge Base Article - Public

3735628 - Only Two Fields Displayed in Case Header

Symptom

Not all fields configured in Adaptation Mode are displayed in the Case Header section [sap.crm.caseservice.uiview.caseDetailsHeader]. After ending adaptation, only the first two fields are displayed in the top-right of the Case Header.

Environment

SAP Service Cloud Version 2

Cause

This behavior is expected and is a part of the system’s design. The top-right area of the Case Header has a fixed layout that supports displaying only two fields. Additional fields may be visible during Adaptation Mode, but they will not be displayed after ending Adaptation Mode.

Resolution

The system is designed to display only two fields in the top-right area of the Case Header. This area has a fixed layout and does not support displaying additional fields, even though more fields may appear during Adaptation Mode.

To highlight more key fields in the header, you can use the “Highlights (Expanded Mode)” section. In this section, you can configure and display up to four additional fields, which will appear when the header is expanded.

Keywords

case header, caseDetailsHeader, fields not displayed, top-right header, status and priority only, highlights expanded mode, adaptation mode, fixed header layout, service cloud v2, sap crm caseservice uiview, header fields, case ui, runtime vs adaptation, ui limitation, header highlights, sap.crm.caseservice.uiview.caseDetailsHeader, Case Header, Adaptation Mode, Status, Priority, Highlights, Expanded Mode, Field Configuration , KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , CEC-CRM-CZM-EXT , Extensibility for SAP Sales/Service Cloud , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 all versions ; SAP Service Cloud Version 2 all versions