Symptom
In the Customer Browser View app, when accessing the CDS View I_FinancialTransaction, an error message saying "You either do not have the required authorization or there is no data to be displayed" will appear.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open the Manage Customer Data Browser app and select the custom CDS view created with scenario "Standard CDS View".
- Enter "I_FinancialTransaction" and access it, an error message saying "You either do not have the required authorization or there is no data to be displayed" will appear.
Cause
Missing authorization for Financial Transaction data sources.
Resolution
Add the following Business Catalogs to desired Business Role:
- SAP_FIN_BC_TRM_MFT1_PC
- SAP_FIN_BC_TRM_MFT2_PC
Keywords
Customer Browser View, CDS View, I_FinancialTransaction, I_FinancialTransactionDEX, financial transaction, missing columns, Authorization, Business Role, Business Catalog, SAP_FIN_BC_TRM_MFT1_PC, SAP_FIN_BC_TRM_MFT2_PC, Treasury and Risk Management , KBA , FIN-FSCM-TRM-2CL , Treasury and Risk Management (Public Cloud) , Problem
SAP Knowledge Base Article - Public