SAP Knowledge Base Article - Public

3736299 - Translation of National ID in Rehire Duplicate Check - Employee Central

Symptom

The translation of the National ID is not working for National ID Number in the duplicate check during the rehire process. 

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

  • SAP SuccessFactors HCM Suite
  • SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Go to Add New Employee;
  2. Fill out the data and click continue;
  3. Duplicate Check pops-up;
  4. All fields are translated to the logged in language, except the National ID Number.

Cause

The system is showing the identifier of the field, instead of the label and identifiers does not have translations. 

Resolution

This is the system's current design in which the identifier is displeyed.

If this is something you wish to be implemented, we encourage to raise an enhancement request and it will be evaluated for future releases (learn more at 2090228 - How to submit enhancement ideas for SAP SuccessFactors Products).

Keywords

translation issue, national id, national id number, duplicate check, rehire process, add new employee, language translation, employee central, rehire, translations, successfactors , KBA , LOD-SF-EC-HIR-RIE , Rehire Inactive Employee , LOD-SF-EC-ADM , Admin Tools (EC Core only) , Product Enhancement

Product

SAP SuccessFactors HCM Core 2511