Symptom
When accessing the "Customer Data Browser" app and searching for the CDS View I_SalesDocumentPricingElement or I_SalesOrderPricingElement, only a small number of Sales documents is getting returned.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Go to the Customer Data Browser app.
- Search for CDS Views that represent the header of sales documents (I_SalesOrderPricingElement, I_SalesDocumentPricingElement...)
- See that a small number of documents is getting retrieved (This depends on the data that is stored in the environment, in some cases a huge number of documents will be retrieved)
Cause
The I_SalesDocumentPricingElement and I_SalesOrderPricingElement are related to the header pricing of any Sales Document. The header price only runs in runtime and calculates from the various items in that particular sales document. It is not stored in any table. The only time it is possible to see any record in these views, is if someone has manually created a condition in the headers.
If the number of documents appearing is small, it is because the app only shows when someone has created those conditions manually in the header of that document.
Resolution
If it is necessary to check the Conditions related to Sales Document, SAP recommends to check in the item level views such as I_SalesDocItemPricingElement or I_SalesOrderItemPricingElement.
Keywords
CDS, View, I_SalesDocItemPricingElement, customer, data, browser, I_SalesDocumentPricingElement, I_SalesOrderPricingElement, pricing, header, item, level, condition , KBA , SD-FIO-SLS-2CL , Sales Apps (Public Cloud) , Problem
SAP Knowledge Base Article - Public