Symptom
CSV File import via Data Import and Export tool shows completed but in the total count it displays 0 records. Besides that, the change is not reflecting in the system.
Environment
SAP Sales and Service Cloud Version 2
Reproducing the Issue
- Open Data Import and Export view.
- Click on import button.
- Select create.
- Select the Entity.
- Uncheck complete entity.
- Enable simulation mode.
- File type as CSV.
- Select the file.
- Click on import data.
Cause
CSV Formatting issue. When the file is opened with text editor such as Notepad, it's possible to note the CSV file was saved with semicolon separators and enclosing double quotes instead of a comma-delimited format, so the data import tool processed 0 records.
Resolution
- Open the source file in a plain text editor and review the raw data. If there are semicolons and enclosing double quotes, the format is incorrect.
- Re-save or export the file as CSV (Comma delimited (.csv)), ensuring fields are separated by commas.
- Do not save the file as UTF-8.
- Re-run the import with the corrected CSV.
- If the issue persists, try importing an Excel file type or export the CSV using a different spreadsheet application and import again.
Keywords
data impex, import completed 0 records, zero records imported, csv, comma delimited, semicolon, double quotes, encoding, utf-8, entity, data import, service cloud v2, csv formatting , KBA , CEC-CRM-IMX , Data Import/Export for SAP Sales/Service Cloud , Problem
SAP Knowledge Base Article - Public