Symptom
- Customer is not receiving email notification with the job results from Proxy Import feature.
- After uploading the file for proxy import, the Proxy Import page displayed the results of the import as successful, but the changes are not applied.
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Upload a Proxy Import file to assign substitute permissions as per guidelines on Proxy Management in Admin Center | SAP Help Portal
- The application shows the file was uploaded successfully.
- No confirmation/result email is received/sent.
- When checking users' permissions, the expected proxy/substitute assignments are not applied.
Cause
- The End Date value in the Proxy Import file is set to 9999-12-31; after timezone transformation this exceeds the supported year range and the process fails silently.
- The date fields in the CSV use an incorrect format; the tool expects dates in the format yyyy-MM-dd HH:mm.
Resolution
When using far-future End Dates, the system might not process the import internally. We recommended you to use a near-future End Date, within the next 20 years to avoid import process breaks.
Additionally, ensure all date fields strictly follow the format yyyy-MM-dd HH:mm (four-digit year, two-digit month/day, 24-hour time).
See Also
- KBA 3558522 - Proxy not created during Proxy Import
- Proxy Management in Admin Center | SAP Help Portal
Keywords
proxy import, notification email, email not received, substitute permissions, proxy rights, results not applied, end date 9999-12-31, timezone transformation, date overflow, date format yyyy-MM-dd HH:mm, csv format, upload success no email, sap successfactors proxy, proxy assignments, import notifications, proxy, INC22706376, , KBA , LOD-SF-PLT-PRX , Proxy , LOD-SF-PLT , Platform Foundational Capabilities , Problem
SAP Knowledge Base Article - Public