Symptom
Lifecycle Analysis runs remain in an In Process status for an extended period (over 10 days) without completing. The application logs show warning messages, but no errors are recorded for these prolonged runs.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Information Lifecycle Management work center.
- Navigate to Lifecycle Analysis Runs view.
- Change the filter dropdown to All Logs.
- Observe runs that remain in status In Process for extended time.
Cause
The probable causes are as follows:
- Due to a very large data volume to be analyzed by the Lifecycle Analysis Run which causes exceptionally long runtimes (mostly tens of millions of items).
- Parallel/recurring scheduled runs lead to locking and blocking, resulting in the message that another run is still in process and preventing completion of new runs.
Resolution
Cancel all currently active Lifecycle Analysis runs. Additionally, disable any weekly recurring or scheduled Lifecycle Analysis jobs to prevent parallel executions.
Steps to cancel a job:
- Go to Application and User Management Work center
- Go to Background Jobs view
- Select the Filter All Running Jobs
- Select the run description with Lifecycle Analysis.
- Select Cancel Job
Manually start a single Lifecycle Analysis Run and ensure no parallel runs are active. Allow the run to proceed without interference; expect long runtime due to the large dataset (potentially more than 10 days).
Keywords
lifecycle analysis run, in process, stuck, ilm, information lifecycle management, long runtime, parallel runs, scheduled job, locking, document deletion run, ILM_BO_NETWORK_RUN, application log warnings, retention start date warning, retention periods, data volume , KBA , AP-RC-ILM , ByD,C4C,Travel: Information Lifecycle Management , Problem
SAP Knowledge Base Article - Public