SAP Knowledge Base Article - Public

3738129 - Error "Enter a valid bank account number" is displayed when migrating "Customer" object

Symptom

While performing the migration of the 'Customer' object the error "Enter a valid bank account number" - (Message class: R111, Message number: 18) occurs. 

Environment

SAP S/4HANA Cloud Public Edition. 

Reproducing the Issue

  1. Open 'Migrate your data' application.
  2. Select the 'Customer' object. 
  3. Fill out the Bank Data sheet. 
  4. Upload the XML template file
  5. Run the simulation for 'Customer' object.

Cause

Neither the fields 'account number' nor 'IBAN' were provided in the Bank Data sheet of the template file. 

One of the those fields are mandatory, either the field for 'account number' or 'IBAN'. 

Resolution

    When maintaining the banking data, either maintain 'Account Number' or 'IBAN', do not maintain both of them. It is mandatory to fill one of those fields.

    Refer to the SAP Note 2470789 for example of a data migration template XML. 

    See Also

    Keywords

    migration cockpit, customer migration, bank data, bank key, bank country, r111 18, enter a valid bank account number, iban, account number, validation error, business partner, s/4hana public cloud, customer bank details, data migration, mandatory fields, r11118.  , KBA , CA-GTF-MIG , SAP S/4HANA Data Migration Cockpit Content , LO-MD-BP-2CL , Business Partners for Public Cloud , Problem

    Product

    SAP S/4HANA Cloud Public Edition all versions