SAP Knowledge Base Article - Public

3738133 - Error messages V2703 or V2111 are appearing when trying to change a field in a Sales Order - SAP S/4HANA Cloud Public Edition

Symptom

When trying to change any field of a Sales Order, the error messages below are appearing:

Sales document cannot be saved (see log)

Message no. V2703

Diagnosis

Via the custom code in Enhancement Option 'Sales Document Check Before Save' an abortion of the sales document saving process was triggered.

System Response

The sales document cannot be saved.

Procedure

Check the log for error messages to find out more details on the reason for the abortion of the document saving process.

 

 

 

One or more errors have occurred. For more information, see the log.

Message no. V2111

Diagnosis

One or more errors have occurred while processing your inputs.

 

Procedure

You can display the log on the overview screen for sales documents. Read the error messages and take the necessary actions.

Environment

SAP S/4HANA Cloud Public Edition

Cause

One of the possible reasons is that, the Business Add In (BADi) "Check of Sales Documents Before Saving (SD_SLS_CHECK_BEFORE_SAVE)" is preventing the value change in the field due to it being a Mandatory check in the custom logic.

Resolution

To fix this issue, there are 2 options:

  1. Deactivate the Cloud BADi entirely and repeat the process
  2. Go to the "Custom Logic" app and temporarily comment out the code in the BADI SD_SLS_CHECK_BEFORE_SAVE that sets the mandatory field check.

See Also

Keywords

BADi, business, add, in, cloud, sd, sls, check, before, save, error, message, V2111, V2703 , KBA , SD-SLS-SO-2CL , Sales Orders (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions