Symptom
Snowflake is not in the data source list when create connection is SAC.
Environment
- SAP Analytics Cloud (Enterprise)
Reproducing the Issue
- Go to Connections in SAC.
- Select Add connection.
- Search for "Snowflake" as a data source.
- Observe that Snowflake is not available.
Cause
To create live data connections to Snowflake, SAC must be running on HANA Cloud.
To check whether your tenant is running on SAP HANA Cloud, click About menu in SAC. The SAP HANA Cloud version will be displayed in the dialog if your tenant runs on SAP HANA Cloud. If you can't find any reference to an SAP HANA Cloud version in the dialog, your tenant is running on SAP HANA 2.0.
Details can be found in the SAC help guide: About Live Data Access | SAP Help Portal
Resolution
How to verify if your SAC is running on HANA Cloud:
- Verify the tenant runtime:
- In the tenant, open About.
- If an SAP HANA Cloud version is shown, the tenant runs on HANA Cloud; if there is no reference to an SAP HANA Cloud version, the tenant is not on HANA Cloud.
The migration to HANA Cloud information can be found in the link SAP Analytics Cloud infrastructure is moving to SAP HANA Cloud.
As a temporary alternative, use an import data connection to Snowflake and load data on a schedule. Detailed steps can be seen in the link Connecting Analytics Cloud to Snowflake (Import mode).
See Also
- Refer to: Prerequisites and restrictions for Snowflake live data connections
- Refer to: Connecting SAP Analytics Cloud to Snowflake (import mode)
- Refer to: Knowledge Article 3469365 - Request to provide Live connectivity of Snowflake from SAC
Keywords
snowflake, connector missing, not available, live connection, sac connections, hana cloud, data federation, live data connection, connection setup, data source search, connector visibility, haas, sac, snowflake live, prerequisites , KBA , LOD-ANA-LDC-HAN , SAC Live Data Connection HANA , Problem
SAP Knowledge Base Article - Public