Symptom
When you navigate to (Ex: Case view), you are not able to see the Attachment Section, or it is loading an empty screen.
Environment
SAP Sales and Service Cloud version 2
Reproducing the Issue
Scenario 1:
- Login to the SAP Sales and Service Cloud Version 2 System
- Open the Case UI.
- Attachment section is not visible.
Scenario 2:
- When you navigate to Case view--> Email
- Click Create--> Email
- Click "Add Attachment", the screen is empty.
Cause
The possible cause is that, user's assigned Business Roles might not be having the relevant Business Service ID "sap.crm.service.documentService" assigned and it's corresponding AppList is not enabled.
Resolution
In order to view the Attachment section, kindly ensure the follwing:
For User's who are having Admin Roles:
1) Navigate the required Business Role.
2) Ensure that the "documentService" is added in the Business Service List.
3) Now, in the App List, kindly ensure both "Document Administration" and "Document Management" is enabled.
4) Now, for users are assigned with Non-Admin Role, kindly ensure "Document Management" is enabled.
5) Also, if you are using the Chrome browser, right click on the Reload Icon and select "Empty Cache and Hard Reload" option.
Keywords
KBA , CEC-CRM-DOS , Document Service for SAP Sales/Service Cloud , Problem
Product
Attachments
| Empty Cache Hard Reload.jpg |
SAP Knowledge Base Article - Public