SAP Knowledge Base Article - Public

3738624 - Data Workbench: Relationship External Key Considered Missing During Business Partner Relationship Import

Symptom

Relationship external key considered missing in data workbench despite being filterable; error: "External Key does not exist" during Business Partner Relationship import can be verified in the data workbench error CSV.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Open Data Workbench.
  2. Start an import for the Individual object.
  3. Select Business Partner Relationship.
  4. Import the sample files which includes both an external key for a account and individual customer as relationship key 1 and 2 respectively.
  5. Run the import and received the error.

Cause

External Keys are type-specific for Business Partners. When importing a relationship between different Business Partner types (for example, Account to Individual Customer), the system cannot resolve the External Key of the second Business Partner across types, causing “External Key does not exist.”

If 2 accounts or two individual customers are used instead the system may resolve it without error.

Resolution

  1. Open the Business Partner Relationship import template/CSV in Data Workbench.
  2. For relationships between different Business Partner types, replace the External Key of the second Business Partner with its Internal ID.
  3. Run the import in simulation mode to verify that the relationship is resolved successfully.
  4. Execute the import.

Keywords

data workbench, business partner relationship, external key, internal id, type-specific key, individual customer, account, import error, external key does not exist, simulation mode, relationship import, data migration, bp relationship, csv import, resolve key , KBA , LOD-CRM-INT-DWB , Data Workbench , Problem

Product

SAP Cloud for Customer core applications all versions