SAP Knowledge Base Article - Public

3738742 - Error "Sorry, the app could not be opened" occurs while accessing the "My Inbox - Approve Timesheets" app in SAP S/4HANA Cloud Public Edition

Symptom

  • Unable to access or process work time approval notifications from "To-Dos" list
  • Unable to access the "My Inbox - Approve Timesheets" app.
  • Error message displayed as  "Sorry, the app couldn't be opened. The navigation target '#TimeEntry-approveTimesheetInbox?sap-app-origin-hint=' of the app could not be resolved.This can be caused, for example, by an incorrect content configuration, an incorrect or missing role assignment, or because your current device is not supported." 

Environment

SAP S/4HANA Cloud Public Edition

Cause

  • The issue is caused by missing authorization.
  • The required business catalog SAP_HCM_BC_TS_WIAPPROVE_PC, which enables approval and rejection of time entries in the My Inbox – Approve Timesheets app, is not assigned to the user’s business role.

Resolution

Assign the required business catalog "SAP_HCM_BC_TS_WIAPPROVE_PC" to the user by adding an appropriate business role. 

Keywords

my inbox, approval of working times, timesheet approval, non-actionable task, empty task, ghost item, notification leads nowhere, flexible workflow, no workflow configured, my inbox item not opening, timesheet workflow, CA-INB-FIO, s/4hana cloud public edition, fiori inbox, workflow administration , KBA , CA-TS-S4 , Cross Application Timesheet in S/4HANA , CA-INB-FIO , Fiori UI for My Inbox Application , Problem

Product

SAP S/4HANA Cloud Public Edition all versions