SAP Knowledge Base Article - Public

3739116 - Filter by product is not working in the Manage Sales Orders Version 2 app

Symptom

When trying to search for sales orders documents using the filter "Product" in the Manage Sales Orders Version 2, the filter is not working.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Access Manage Sales Order version 2 in the 2602 version of SAP S/4HANA Cloud Public Edition
  2. Add a product in the "Product" field and try to filter the Sales Orders
  3. The filter doesn't work and all Sales Order in the system are listened 

Cause

The filters are not properly applied anymore, and in some cases the filters are not being present in the adapt filters dialog. This behavior was especially noticed within the Manage Sales Order V2 application.

This is a known error by SAP, which was already fixed by Development team, however it still needs to be rolled out for the production environment of SAP S/4HANA Cloud Public Edition.

Resolution

This is already implemented and is included in an upcoming patch level (UI5 1.142.8) which will become available in our customer production environments at 18th/19th of April.

As a temporary workaround, it is possible to enter the product number in the Search field. Kindly note that, this is a fuzzy search across multiple fields, so the result list may still contain additional entries in some cases. However, it should help narrow down the list until the patch is applied.

See Also

list, filter, manage, sales, orders, version 2, bug, 2602, development, regression

Keywords

KBA , SD-SLS-RE-2CL , Returns (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions