Symptom
The "Created By" field in Supplier Invoice which was created via Web service is blank.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Supplier Invoicing Work center.
- Go to Invoices and Credit Memos view.
- Search for ABC (ABC represents Supplier Invoice ID).
- Select Edit.
The "Created By" field is blank and No Technical or Business user is displayed.
Cause
- When Web service was logged in using a Technical user (regardless of whether Authentication is Username/Password or SSL Certificate), the system does not populate the “Created By” field.
- To check the Authentication method, follow the below steps:
- Go to Application and User Management Work center.
- Go to Communication Arrangements view.
- Select Edit.
- Go to Technical data tab, here Authentication method field will be seen.
- The “Created By” field is only populated in Supplier Invoice when the Web service is logged in using a Business user.
- The system will display the users in "Created By" field when there is a business partner involved with the user. The Support users and Technical users does not have business partner mapped against them and hence, the system will not display the created by details
- For subsequent changes through Web service, the change log records the user (Technical or Business user) accordingly.
Resolution
This is the standard system behavior.
If this behavior needs to be enhanced, we kindly recommend submitting a requirement in the SAP Customer Influence forum using the following link: <https://influence.sap.com/sap/ino/#/campaign/886>.
See Also
Keywords
Supplier Invoice; Created by; SSL Certificate; Communication Arrangement; Technical user; , KBA , AP-SIP-SIV , Supplier Invoice , Known Error
Product
SAP Business ByDesign all versions
SAP Knowledge Base Article - Public