Symptom
You have created contacts and assigned them to Customer or Supplier by using the migration object "X - extend existing record by new org level" (where X represents the object, such as Customer or Supplier), however the contact business partners created as a result of the migration do not have a business partner role such as Contact Person (BUP001).
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Create and assign contacts to existing customers/suppliers via migration cockpit (for example for Customer object, following the guidance from Help Center document Help Center - Customer - extend existing record by new org levels)
- Open the Business Partner Master Data app.
- Locate the business partner for the contact created through the migration process.
In the business partner, it is possible to see that there are no roles (such as the Contact Person role BUP001) assigned to it.
Cause
In cases where the contact business partner is created through the extension of existing customers/suppliers in the Migration Cockpit, the business partner is not assigned the Contact Person role.
Resolution
The system works as expected.
In case multiple contact business partners were created and the BUP001 role is required, it is possible to use the Mass Maintenance feature to assign the role to multiple business partners.
More details can be found in the following Help Center document: Help Center - Mass Maintenance.
See Also
Keywords
DMC, migration tool, BP , KBA , CA-LT-MC , S/4HANA Migration Cockpit , Problem
SAP Knowledge Base Article - Public