SAP Knowledge Base Article - Public

3740572 - Advanced Search for the Remote Object ID (Customer) Field in Ticket Creation Returns Unexpected Results.

Symptom

When using the advanced search for Customer, filtering records based in Remote Object ID field. Your search criteria brings what seem to be wrong results. 

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Open an Account that has multiple external ID mappings in “Mapping for Integration” (one marked as Main and at least one additional external ID under a different business system).
  2. Go to Tickets
  3. Create New
  4. In the Customer Object OVS, open Advanced Search and add/display the “Remote Object ID” field if needed.
  5. Enter the Main External ID value in “Remote Object ID” and observe that the account is found.
  6. Enter a non‑Main External ID value in “Remote Object ID” and observe that no result is returned.

Cause

This is Expected System Behavior

Resolution

Only the External ID flagged as Main in the account’s Mapping for Integration is considered by the Customer OVS “Remote Object ID” search during Ticket creation.

Keywords

remote object id, customer ovs, ticket creation, advanced search, external id, main external id, mapping for integration, account search, service ticket, business system, id mapping type, account ovs, search limitation, service cloud, customer search , KBA , AP-RC-UIF-RT , UI Framework Runtime , Problem

Product

SAP Cloud for Customer core applications all versions