Symptom
In the latest people profile (PPX), deleting an attachment from a background element record and clicking Save prevents saving and shows the message "No changes to save."
The same operation works correctly in the legacy people profile (PP3); Changes are saved successfully.
Environment
SAP SuccessFactors Employee Central
- Employee Profile
Reproducing the Issue
- Open the latest people profile (PPX) for any user.
- Navigate to a background element card (for example, Honors/Awards) and select View All.
- Choose a record that currently has an attachment and click Edit.
- Only delete the attachment and click Save.
- Observe that the system blocks the save and displays "No changes to save."
Cause
Confirmed as a product defect in PPX.
Resolution
The defect is scheduled to be fixed in the 1H 2026 release (Preview: 04/13, Production: 05/15).
See Also
- refer to: 2414244 - How to Delete Background Element Data in Employee Profile?
- refer to: 3687625 - Error "changes to your data cannot be saved" when editing employee profile information
- refer to: 2819717 - Cannot configure attachments for Employee Profile
- refer to: 2686888 - Available file types for attachment in SuccessFactors
- refer to: 2255736 - Invalid Attachment error while uploading documents in bulk - Employee Profile
Keywords
ppx, latest people profile, background elements, attachment deletion, no changes to save, save blocked, employee profile, pp3, attachment not saved, delete attachment, profile save error, background card attachments, ECT-264837, INC24125085 , KBA , LOD-SF-EP-BGD , Background Elements , Known Error
SAP Knowledge Base Article - Public