SAP Knowledge Base Article - Public

3741738 - Business partner import registers incorrect first name after editing template in "Import Master Data - Business Partners" app – s/4hana cloud public edition

Symptom

  • When using the "Import Master Data - Business Partners" application, the first name of a business partner is not registered as intended after import. For example, the first name may be replaced by a phonetic annotation.
  • Similar misregistrations can occur in other fields.
  • The behavior can occur across environments.
  • The issue may not occur every time.
  • No error message was reported.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Download the import template file from the "Import Master Data - Business Partners" application.
  2. Manually input first and last names into the downloaded template file.
  3. Import the file and observe that names are incorrectly registered.

Cause

Manual editing of the XML structure in the import template file downloaded from the application is suspected to break the XML and lead to incorrect data registration.

Resolution

1) Manually remove the phonetic annotations, however this will most likely require a high level of effort.
2) Switch from Excel file usage to CSV file usage, which is not as comfortable, but does not require as much effort as the manual removal option.

See Also

refer to: similar case: data import of business partners

Keywords

business partner import, integrated import app, incorrect first name, name mismatch, xml template, manual edit, template corruption, phonetic annotations, kana, csv import, excel template, data registration, mdg bp import, data import issue, business partner data , KBA , CA-MDG-CMP-BP , Business Partner , CA-WFD-INT , S/4HANA Cloud Workforce Domain Integration , Problem

Product

SAP S/4HANA Cloud Public Edition all versions