Symptom
- When trying to schedule reports to email destination using Office 365 SMTP server, the job fails with the below error:
- server error. [CrystalEnterprise.Smtp]: [SSL negotiation has failed during setup of the SMTP server connection, please ensure your SSL configuration is correct on both the client and the server.]
- Tried updating certificate following 2960167
Environment
- SAP BusinessObjects Business Intelligence platform 4.x (BI 4.x), BI 2025
- Microsoft Office 365 SMTP server
- All supported operating system
Reproducing the Issue
- Log on CMC/BI Launchpad as Administrator
- Try to schedule any report to Email destination
- The job fails with the below error:
- server error. [CrystalEnterprise.Smtp]: [SSL negotiation has failed during setup of the SMTP server connection, please ensure your SSL configuration is correct on both the client and the server.]
Cause
- The certificates were not placed at the required location mentioned in AJS>Destination>Email>SMTP Certificate.
- The actual root cause of the issue is an expired certificate, which needs to be updated at regular intervals.
Resolution
- Go to CMC>Servers>Adaptive Job Server>Destinations>Email>SMTP Certificate and note the directory mentioned there.
- Follow KBA 3736462 to update the certificate at the desired SMTP certificate location.
- The downloaded certificate must be present at the SMTP Certificate location in order to establish SSL negotiations.
- Restart the AJS.
- Try to schedule reports again.
See Also
Keywords
SSL negotiation, SMTP Issue, SMTP Server issue , KBA , BI-BIP-ADM , BI Servers, security, Crystal Reports in Launchpad , Problem
Product
SAP Crystal Server 2025
SAP Knowledge Base Article - Public